Acoustic Model Missing

I am using MiraCheck Release, which I believe is the latest version, on a Samsung Galaxy S10 Android phone. In the past, Mira has recognized my voice commands effectively on this phone, but now Mira is not responding to any of my commands. The mic icon is pink when Mira is talking and dark red when listening.

I have the following settings:

Talk to Mira - On
Voice Search - On
Limited Vocabulary - Off (also tried it On)
Follow Up Dialog - On
Listening Time - 10 sec.
Listen in Background - On
Challenge/Response - Off
Show Commands - On (It showed Commands for a while, but now stopped showing)

Audio Settings show:

Audio Input: Built-in Mic (should is say SM-G973U?)
Audio Output: SM-G973U (which is the Galaxy S10)
Headset: Not connected
Interrupt Mira: No

All I can think of is setting the Acoustic Model to another choice for voice recognition, but the Acoustic Model option is not available. Also tried MiraCheck CoPilot on a second Galaxy S10 that I have, and got same results. Should Acoustic Model be available?

I have checked the Galaxy s10 microphone by recording a voice memo, and it works fine. Also, I have run MiraCheck CoPilot on my iPad Mini 6, and voice recognition works beautifully on that device.

Any suggestions for getting voice recognition working on the Android phone(s)?