Mira wakes up but does not acknowledge commands

It started after upgrading to v. 5. Mira wakes up but does acknowledge commands like “check” or “repeat”. Using Bluetooth mic. The connection is ok.

Many people that have this issue have Challenge/Response toggled ON under the Talk to Mira menu. That is an advanced feature where you would need to set up responses for each item. Make sure this setting is OFF.

Also make sure Limit Vocabulary is OFF.

Also make sure Follow Up Dialog is ON.

You can also toggle ON Show Commands to see what Mira is seeing. The overlay of the commands does block the menu. You can always slide out the menu by swiping from the right of the screen as well.

Got it. All the settings you described are active. She is listening now. Thanks

Jeff, I am having trouble with Mira. Listening on the background is not working (it’s checked green). I have to manually activate by clicking on the microphone on the bottom bar. When I do it, I get a long wait then a NLP message. This has happened a few times already. Also, Mira does not understand what I say like “check” (it shows JACK on the command bar). I’ve tried in all different acoustic modes to no avail. None of this was happening in the previous version. Thanks for your help. [EDITED] Ok, I’ve just found this other post “Voice search - impact on recognition rate” and tried to switch off VOICE SEARCH. Now is working with no issues FYI.

Yes, I was just going to suggest to read that.

Would be curious if you want to test it, is if you had Voice Search ON, and said CHECK ITEM instead of CHECK how that performs. Of course, turn it OFF after.

Switched Voice Search back ON. Now she understands both CHECH and CHECK ITEM. It seems to me the recognition engine reseted (i noticed that on the miracheck icon update bar when I switch voice search off).

Sorry I think that is a false positive. I forgot to mention that if you open the same checklist it uses a cached version of the engine, instead of having to initialize it!so probably not using the larger dictionary.

For a proper test.

Make sure mic is OFF.
Open a different checklist.
Turn mic ON.
You should see the NLP initializing.
Now test CHECK ITEM.

ok test completed as described. NLP took over 10-15 seconds to initialize. Does not understand CHECK but acknowledges CHECK ITEM. I will keep voice search off for the time being. It was very frustrating to repeat CHECK multiple times and having to manually check the checklist item while in flight. Glad I was chair flying.

Jeff: I noticed Mira was not waking up (listen in background was checked on). I checked off and on again now she keeps waking up on and off and I can hear the waking sound multiple times. Also when she wakes up does not recognize commands like check immediately. The issue is having to repeat the command multiple times. Note this was not happening in the previous version.

Can you describe in more detail the exact steps you are doing to get it to behave like this? We are not seeing this issue in our testing. I am not fully understanding when you say she keeps waking up on and off and you hear the waking sound multiple times. When you say keeps waking up, what are you defining as her waking up, the Mic icon going from light green to dark red? If you have another phone or camera maybe try recording what you are experiencing.

That would be easier to explain. See this link: https://youtu.be/jYBdQBZsN3U

I see a couple of things wrong with how you are using…

First, when you come into the app, the mic is white with a slash through it. This means voice reco is completely off. You have to tap that to turn voice reco on so it is not listening when you don’t realize it. You only need to do that once when you load the app.

Second, you have Follow Up Dialog OFF. That is why she is also not getting your commands and why she immediately stops listening. The delay is ignored if this is OFF. Turn this ON. This was mentioned in the first issue you posted. With that OFF you always have to prefix the command with the wake word MIRA. There is a help icon next to that as well.

NOTE: None of this has changed since Version 4. This is how it has always worked.

On the slide out menu in Mira, there is a Talk to Mira Help detailing all of this that also has been there since the last version. Please read through this…

Hope this gets you up and running.

1 Like