New Form Items in Action!


#1

With respect to your recent email which included “New Form Items in Action!,” I am having trouble making your sample work on my iPad. I just purchased the new Miracheck 2.xx and have been trying to make the forms work, but I have the same problem with your downloaded sample as I have been having with the forms I designed which is, basically, erratic behavior which seems to be characterized by the iPad keyboard flashing on and off rapidly. It begins to happen after filling in first couple of fields, the the program locks up entirely and needs to be fully closed and restarted. The it will work for a couple of fields and the whole problem returns requiring another close and restart. I have yet to come even close to getting through your entire demo. What the heck am I doing wrong? Many thanks!


#2

Thanks for the feedback. What iPad and version of iOS are you using? Also what version of MiraCheck? You can see this on the Home page in MiraCheck. This will help us try to identify.


#3

It’s your basic iPad. A new one I bought to use with your program. I had been using the old checklist on a Panasonic Android Toughpad.

The model of my iPad is MP242LL/A. The IOS is Version 11.3

Many thanks for your prompt reply.

Mike


#4

Oops … forgot to give you my MiraCheck version. It is: 2.0.2.197


#5

So far trying to reproduce on some other iPads. Went back to an iPad from 5 years back and no luck yet reproducing. Something to try to help identify is to reboot iPad and then try example.


#6

Also, there is a version 2.0.3.205 to update to.


#7

Ok, tried it all, including uploading latest version. Got a bit farther through you demo, then hung up again. Tried a couple of times and the results are erratic, but always returns to the same problem: The keyboard flashes on and off, the program slows down or stops and and I need to shut down the program and reset the checklist to get started again

Sorry.


#8

So far we are not able to recreate on a multitude of test devices. It may help if you can record video of what you are seeing…

Is there anyone else reading this post seeing the same behavior?


#9

We finally were able to reproduce the issue you are seeing. We are working on a fix and hopefully it will be approved by Apple in the next few days. Thanks for your feedback!


#10

Many thanks. I’ve been busy with other things and haven’t had time to figure out how to do the recording you asked for. Sorry about that. But I am pleased to see its not just me. Let me know if I do need to do a screen capture. I might find some time for it this weekend if absolutely necessary. You have a great program which I have been using for a couple of years. I am not a pilot … not any more, anyway … but apply what I learned over the years to a lot of other stuff, including getting our boat underway, anchoring, etc. etc. That’s what I use your program for mostly these days. Which brings me to another question: What I was trying to design when I ran into the flashing keyboard problem was a list to record hourly checks while underway and it would be really helpful if the program would alarm some way every hour … or two hours … or whatever I set it for, to remind me on a long passage to run through the hourly checklist. Is there a way to do that? If fact, it would be great if it would also total up underway hours (time between the start engine task and the shutdown engine tasks) and alarm when I hit a number such as 200 hours for an engine oil change, or alarm on a selected date such as 30 days to check battery electrolyte, etc. Or is there a way to do all this that I have not figured out yet. In any case, many thanks for a great program. I have separate paper checklists for all my maintenance items (it is easy to forget to replace the oil fill cap!) and eventually I will get them all into Miracheck.

Thanks for your attention.

Allbest,
Mike


#11

Mike, it is on the roadmap to have timers and alerting and I will take your use cases into consideration when we get to the design of the functionality. Thanks for the support!


#12

Jeff,
Many thanks for listening. I’m looking forward to what you find out about the dancing keyboard.

Allbest,
Mike


#13

Version 2.0.4 has been released which has fixed the issues with the Text Input fields.