Talk to Mira Information

Talk to Mira enables voice recognition for controlling the checklist. It is one input method of many we provide to control the checklist. Technologies like Siri, Google Assistant and Alexa take advantage of massive server-side processing on voice and have great processing of background noise. They do good for single questions and answers, but not good when you want to interact in real-time like saying check, check, check rapidly.

For MiraCheck the requirement for offline speech-to-text and the ability to react rapidly is essential. The technologies for this have come a long way, but they are not yet 100% ideal. For one, background noise can really affect the accuracy. We have add a background noise slider to help with this. Typical values should be in the 2 to 4 range. The higher, the more it tries to reduce background noise. Too high, and even what you say is considered background noise.

Also, when Mira is speaking she can trip the recognition so by default voice recognition is turned off when she is speaking. You have to wait until she is finished to give a command. We have added a feature Interrupt Mira which will turn this off. Only turn this on when using a headset. When using a headset, since the audio is not being heard by the mic the interruption then can work.

In our testing the voice recognition works really well when paired with a high-end bluetooth headset and there are still a lot of things we are exploring to improve for the future.

Voice recognition doesn’t work. Tried with my headset and with a bluetooth phone headset. Neither worked. Hear Mira clearly. When I say “check”, nothing. Tried adjusting the background noise filter and every other parameter. Nothing works. Doesn’t work in my plane & doesn’t work in the quiet environment at home. Doesn’t work with two different headsets. Just no response at all. Suggestions?

1 Like

Can you share with me the settings you are trying? Slide out your menu from the left and scroll to all the audio features under preferences and while holding the power button on iPhone or iPad click Home button to take a screengrab, and then upload or email the screengrab.

@dgoulding48 Here is the settings you currently have selected…

The issue I see in your settings and why it appears to not be working is you have Challenge/Response Mode enabled in your settings. This is an advanced mode that requires authoring the checklist content in a different way. There is a separate post with information on that mode in this category…
Challenge / Response Information Topic

The Interrupt Mira also should only be enabled when utilizing a headset. As you are trying to get this to work I would initially turn that off as well.

To keep it simple for now I would also turn off Listens Aggressively and set the Background Noise slider between 3 and 3.5.

First do some testing with these settings in a quiet area with no bluetooth yet, just talking directly to the iPhone or iPad.

Your suggested settings worked at home both with and without a headset. Next step is a test in the plane. Thanks.

Really glad to HEAR it!

Did that on my iPad already and sent it. Duplicated the settings on my iPhone exactly except that I cannot turn on the Talk to Mira feature.

I just downloaded the app yesterday and I have the same problem. My menu doesn’t show like dgoulding’s. Did I buy the wrong product? I would want to answer back “check” instead of having to click the box.


There are different plans for the product, a Basic Plan, Standard Plan and Pro Plan. The Pro Plan has the voice recognition. If you click Preview Pro in the app, you should then see the menus to test all the Pro features. If you go to the website and click o the Plans link at the top, it shows the capabilities of the different plans.

I try to turn on Talk to Mira and I get a message that says I need to turn off the app and another that says I need to delete it to give it permission to turn in the microphone

I am not sure what selections you made the first time. I would suggest starting clean. Delete the app and download again from the App Store. When click the Mic, make sure to give proper access. The first time it will say to turn on one more time. Let me know if you run into any issues.