Talk to Mira not working in Baron

I am able to talk to Mira on the ground and go through all of my checklist. I have a B 55 Baron and with engines running even on the ground I cannot use voice commands to Check and go to the next item. I
usually can go through several items on the checklist and then it just seems to shut down. I use Lightspeed Zulu 3’s and connect with Bluetooth. I would appreciate any advice.

One thing to do is when you headset is paired, click the Show Audio Status action on the menu. This will confirm if the audio is being routed over bluetooth or still just using the devices mic and speaker. If it is all using bluetooth, one thing we have tested is the Zulu 3 doesn’t do a good of job as a Bose A20 for example as far as the mic on the headset cancelling background noise. With a twin, the amount on noise from the two engines may be causing some issues. It looks like you have Show Commands on. When you try to speak commands when it is not working what do you see reported at the top of the screen?

The Zulu 3 does have a pretty unknown feature for adjusting the mic gain. You may try adjusting this setting if the issue is it is getting too much noise from the engines.

You can learn about adjusting it in the FAQ

…and search the topic ‘What is mic gain and how do I adjust it’

For what it’s worth, I have the same issue in my Baron 58, albeit with a Bose A20. It will just work if I shout and repeat responses. I’ve tried with both a “straight” checklist and challenge/response. I think I get no response with Show Commands on, but will confirm next flight. I have Mira on my phone and link through Bluetooth to the headset. Works great at home in testing. I’m happy to participate in this thread to see if there are some settings to adjust to see what delivers the best performance. I’m using Acoustic Model 4 at the moment, but haven’t seen a big difference from 1. It would be great to tweak the settings for a better response rate, but it is a noisy cockpit!

Hey Jeff. Thanks for the reply. I had already tried turning the Mic gain up. I haven’t been able to get back to the airplane to experiment but I did turn up TV volume to simulate a noisy environment. Voice recognition actually seemed to work better with the mic gain turned down (not as sensitive to background noise maybe?). Someone had posted on YouTube Baron engine sounds to accompany a flight simulator so I played that on my phone close to the mic while I ran MiraCheck on the IPAD. That pretty much reproduced what happened in the airplane. It will go through about 4 items and then stop. Even if I then manually check an item and then continue it will not recognize the voice “check” response. When I checked the command bar there were various words like Kirk, Kirkland, and others but not Check. I kept trying and finally got the error message shown in the attachment. Any ideas?



I thought it was just me. Hopefully we can get this straightened out. I was thinking it was confined to the Lightspeed. Glad I didn’t order the A20.