Unable to Log into MiraCheck/Goose Cloud from MacBook Pro

I normally edit my checklists on a MacBook Pro while updating on an iPad. When I try to log in, I now get an Info: Signature Expired… Alert and the spinning balls just keep spinning.

Am able to log into Cloud from the iPad running a checklist so don’t believe that this is an account problem.

Any ideas?



Hi @tommyn,

that sounds odd. Just to confirm, all good & no issues logging into your account on your iPad. But you have problems using the Goose Cloud?

I tried to recreate the problem without success. Loggin in & out works as it is supposed to. I tried Safari, Chrome and Firefox. It all worked like it should.
With that in mind I have a only three ideas what could have gone wrong.
If neither works, I need some more help trouble shooting.

My ideas & initial thought:

  1. Bad Timing → Deployed new Version ?
    We had a few updates rolling out today. This might (!) have been just some bad timing where you tried to access the web app the same time we deployed some changes behind the scenes.
    In that case you should now be able to access Goose Cloud without any issues. Just to be 100% safe, try open & refresh the website with a cleared cache. (for example: when using Chrome browser on Mac: CMD + Shift + R)
  2. Browser Issues ?
    not sure what or why something like this can occur
  3. Bad network connection ?
    Sorry to suggest that, but maybe your network had some issues. I personally use speed.io to check if my connection has troubles.

If neither if these work, please let me know:

  • Which browser do you use?
  • Which version of Goose Cloud are you trying to log into?
    If it’s not “Version” or later, please clear cache and refresh
  • Please send the link you are trying to log into.

If the problem remains unsolved, we can always schedule a quick call to see if we can fix that.

Hope this helped already!
Many thanks

Thanks Mirko for the quick response. I have good connectivity, am using the page that has the latest Cloud version and have cleared everything imaginable in Safari. Verified that problem also exists in Chrome.

The Login is Goose Cloud After a lot of fiddling, the only improvement I got was a rotating square but this quickly reverted to the spinning balls.

I always get an I Info Alert. Here is a sample message (it changes with the time): Signature expired 20240520T225951Z is now earlier than 2024050T235458Z (20240520T235958Z - 5 min )

Hope that this helps.


Hi Tom,
can you send an email to support@aerosys.io please?
I want to provide you with a test-account + password to try that.
Additionally, I would like to dive into account details, logged in devices, etc. None of which I am comfortable discussing through the public channels.

Also I suggest, jumping on a quick call (ideally Teams or Zoom) where you can share your screen.
In preparation, I suggest you change your password - just to be absolutely safe.
The call shouldnt take much longer than 10-15 minutes and I am happy to work around your schedule.

Many thanks

Hi @tommyn ,
just wanted to follow up if you can log into Goose Cloud again?
From our side I / we could not find any issues.

If the problem persists, I suggest to send an email to support@aerosys.io, so we can schedule a video call to address that issue together.

Looking forward to hearing back
many thanks