Version 3 and Bluetooth disconnect beeps


#1

With version 3, connected to my Bose A20 headset, I keep getting beeps in the headset as MiraCheck connects and disconnects from the audio. I don’t use voice commands with Mira - I did try setting “Mira listens always” in the preferences but to no avail.

After about 5 seconds of inactivity, I get a beep in the headset… when I touch on a check item or the Check button, there is a pause, another beep and then Mira speaks the item.

The pause is very annoying and distracting especially when setting up for approach.

How can I revert MiraCheck back to the V2 and before behavior where there were no beeps???

I’ve tried different BlueTooth compatibility modes, no joy… Rebooted the iPad (on latest iOS release BTW)… I didn’t have this problem before the V3 update installed itself.

Thanks
Stu


#3

UPDATE…we were able to reproduce the issue you are experiencing. We need to look into how it can be addressed. For the time being as a workaround it looks like if you click the Mic after loading the procedure to turn Talk to Mira on it then doesn’t keep switching audio. You can set the Listen Delay to 5 seconds and never use the wake word if you don’t want to use commands. You can also turn off Audio from the slide out menu. As soon as we can find a solution we will release an update.


#4

Thank you! MiraCheck without Audio is like Ying without Yang, Snoopy without Linus or Orville without Wilbur!

MiraCheck with audio provides me with a heads up checklist that allows flow & challenge/response to be seamlessly integrated - a real step forward in cockpit utilization of checklists.

In my prior aircraft, this functionality was provided by a product from Heads Up Technologies - still available and last I looked, about $12K + installation - but now only in a Zsus pedestal form factor. No room for this in the current aircraft so MiraCheck is an awesome replacement.

I’ll look at the workaround on my flight home this afternoon!
Appreciate the speedy response!

Stu
TBM910 driver…


#5

Your words are a great testimonial! We will try to get this issue fixed promptly. Can I use your words as a testimonial?


#6

You can happily use my words! Probably better not to mention the Heads Up folks - they have a great product, just limited form factor.

Cheers
Stu


#7

Thanks. Perfect. Wilco.


#8

FWIW, I just tested the work around with a Bose QC30 BT headset - I could reproduce the two beep problem as I described with the A20. I enabled “Talk to Mira” and set the listen period to 5 seconds as you described. Clicking off the microphone button on the flyout has Mira saying “Goodbye” BUT… when I click on an item or button, there is a beep followed by a pause before Mira reads the item into audio.

If you pause activity with Mira for about 10 seconds, there is now no departing beep BUT there is still a beep when you next interact with Mira and the pause.

Before V3, the interactions via the buttons or touching on a check item was instant - now there is the beep and a delay after inactivity. Clicking on items without inactivity, as in tapping the check button in succession shows no pause or hesitation.

This is on the QC30 - will try in the plane later today.

Thanks and hope this helps.
Stu


#9

Success! We have identified the issue and there will be a fix soon. It will behave how v2 was behaving. We have to do thorough testing on it and get through the Apple review process which will take a few days, but hopefully will be there by this end of weekend. Thanks for your feedback!


#10

The Apple review process went very quickly this time around. Version 3.0.3 of the app which should fix the bluetooth audio issue has been approved. Look for it in the App Store over the next 24 hours.


#11

Thank you for the very quick turnaround! I was able to use the workaround you described earlier after re-reading the description. Enabling “Talk to Mira”, setting the stop listen to 5 seconds and then letting Mira say Goodbye nailed it.

Verified on the flight yesterday.

Thank you again!!!
Stu